fastly compute update

Update a package on a Fastly Compute@Edge service version.

Syntax

$ fastly compute update --version=VERSION --package=PACKAGE

Options

KeyRequired?DefaultDescription
--service-idNoService ID (falls back to FASTLY_SERVICE_ID, then fastly.toml)
--service-nameNoThe name of the service
--versionYes'latest', 'active', or the number of a specific version
--autocloneNoIf the selected service version is not editable, clone it and use the clone.
--packageYesPath to a package tar.gz

Global options

KeyRequired?DefaultDescription
--helpNoShow context-sensitive help.
--accept-defaultsNoAccept default options for all interactive prompts apart from Yes/No confirmations
--auto-yesNoAnswer yes automatically to all Yes/No confirmations. This may suppress security warnings
--non-interactiveNoDo not prompt for user input - suitable for CI processes. Equivalent to --accept-defaults and --auto-yes
--profileNoSwitch account profile for single command execution (see also: 'fastly profile switch')
--tokenNoFastly API token (or via FASTLY_API_TOKEN)
--verboseNoVerbose logging

Examples

Update a package on the currently active service version

Uses the --version flag to select the currently active service version and the --autoclone flag to enable automate cloning of the service version.

$ fastly compute update --package ./pkg/example.tar.gz --version active --autoclone

API equivalent

This command internally uses the following Fastly public APIs: